Apache 2.4.20 升级 2.4.43问题汇总


1、Apache编译安装过程中,提示failed
报错提示:nghttp2 version is too old
解决方法:sudo yum install libnghttp2-devel
解决说明:需配置Centos EPEL源,libnghttp2-devel版本为1.31.1-1.el7,虽然不是最新版但可用。
参考链接:https://blog.k-res.net/archives/2384.html


2、安装成功提示后出现的问题1
问题过程:执行操作service httpd start后出错
报错提示:AH00534: httpd: Configuration error: No MPM loaded
解决方法:将”LoadModule mpm_prefork_module modules/mod_mpm_prefork.so“添加到http.conf中
参考链接:https://stackoverflow.com/questions/30833462/ah00534-httpd-configuration-error-no-mpm-loaded
https://unix.stackexchange.com/questions/209548/ah00534-httpd-configuration-error-no-mpm-loaded


3、安装成功提示后出现的问题2
问题过程:解决问题1后,执行操作service httpd start后继续出错
报错提示1:AH00526: Syntax error on line 36 of /conf/extra/httpd-ssl.conf
报错提示2:Cannot define multiple Listeners on the same IP:port
解决方法 :修改配置文件httpd.conf,在其中的”Listen 443 “行前添加#号注释,即改行修改为”# Listen 443 “
解决说明 :根据错误提示,排查配置文件httpd-ssl.conf第36行内容为”Listen 443 “进一步联系后续错误提示存在重复监听端口问题,想到在httpd.conf中可能有同样监听443端口,说明可能存在冲突,将其中一个注释即可(未验证注释httpd-ssl.conf中的监听端口是否可行)


4、未解疑惑:Apache 2.4.43版本的配置文件与旧版本不兼容?

“每天的雨如期不绝,六月的童心不在,昨天也回不来”

点击数:780

发表评论

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据

返回顶部